SunRuanEr
 subscriber, 177 posts
Tue 17 Dec 2019
at 13:27
Re: RPoL Design Update
Thanks for the fixes, Jase! For the other stuff...

jase:
SunRuanEr:
You know how there's the warning that comes up when you hit post if a new message has been posted to a thread (if one came up while you were in the writing window, so RPoL doesn't think you've seen it) that forces you to acknowledge it before you submit your post?

I've always gotten that on the old site, even when I preview my own post (which is good, because the most recent post in the thread isn't even viewable on the screen if the previewed post is of any decent length). On the responsive site, I am NOT getting that warning if I have previewed the post before hitting submit.

I thought if you previewed (or posted) after another message had been added it gave you that warning but then it disappeared after.

I'm used to seeing the warning come up at the top of the screen when I preview a post, or go to add a post, and there's been a new post posted between the time that I opened the posting window and when I previewed/hit post. It -does- disappear after you acknowledge that the warning is there. The issue is that on responsive, the warning isn't coming up at all when you preview your post (it does come up if you go straight to 'post' without previewing, but if you preview before you post there's no indicator.)


quote:
SunRuanEr:
1) I have no option to preview the post as another character that I control that has access to whatever Group the thread that the post is being made is in. I have the option to preview the post as characters I control that do not have access to the Group, and as every other character regardless of their Group access.

Can't see the point in needing to do this, none of your other characters should be in the list except those tagged as a player.

There's not one, I just noticed the idiosyncrasy when checking to replicate the issue that was forcing posts to become PMs. Especially because the preview list included some of my controlled characters (tagged as player or otherwise) but not all of them. Wasn't sure if it was somehow related to the forced-PM issue, so I figured I'd mention it.

Specifically because I was being given the preview option for characters that didn't have access to the thread group where the post was being made (and ergo shouldn't be able to see it at all), but not for ones that did have access to the group being posted in. It just seemed... strange. Not an issue, though, since you fixed the funky forced-PM issue. :)

quote:
SunRuanEr:
Private TO Language Group seems to NOT be working on responsive. No indicator that there was a private line there that a character should be able to see, or anything - just nothing at all, when the private to language group is used.

I can't replicate that problem.  Are you using "group" in the address?  e.g. "Private to group Elvish"?


I'm using the 'Insert a Private Line > Private to group (language>' option from the drop-down selector. I don't trust myself to write those by hand!

If I use the 'The Language group' option, where text appears but is scrambled if you don't have the language, the entered text appears. If I use the 'Private to group <language>' option, that should only display to the characters that have the language, nothing appears at all for them even when it should. This is only on responsive, it works on live.

quote:
Also don't forget part of the notice when previewing as someone else -- As a player previewing as another all private/secret lines to groups will be hidden and all languages will be scrambled regardless of the recipient -- this is deliberate otherwise you could find out who's in the private groups.

Fair point, I had forgotten that part. :)

Point was, though, that there's no indicator to the author of the post that their intended recipients can't see the private lines. On their end, the 'Private to group <language>' text appears as it was written. It's just not showing up on the other end. (Which is totes working as intended, obviously, just clarifying that the borking is ONLY on the recipient's end) It's almost impossible to tell unless you have someone go 'hey, didn't you catch that I said this?' only to find that there's nothing there to catch. Or, in my case, my spouse wrote a post that I knew had some language lines in it that my character should have been able to read, but when I went to look at it later on my machine there were no visible language lines... so we started digging. I'm not sure why it won't replicate for you, because we can reproduce the error every time. (and can double-check on live to verify that over there, it's working properly)

This message was last edited by the user at 13:36, Tue 17 Dec 2019.

jase
 admin, 3739 posts
 Cogito, ergo procuro.
 Carpe stultus!
Tue 17 Dec 2019
at 23:13
Re: RPoL Design Update
Managed to replicate the private to group issue and then tracked down the bug.  Ironically the part that was hiding it when previewing as someone else was also hiding it whenever you were viewing it as well (unless you were a GM).

Will have to take a look at the others when I've got more time.

Thanks (to all!) for reporting all the bugs.  Clearly I can't catch 'em all!
SunRuanEr
 subscriber, 178 posts
Tue 17 Dec 2019
at 23:33
Re: RPoL Design Update
Yay, it's fixed! I was just running here to jump around excitedly about that!

Thanks a bundle, jase! :)
SunRuanEr
 subscriber, 198 posts
Sun 2 Feb 2020
at 01:04
Re: RPoL Design Update
Not sure if this has already been mentioned, but it seems that embedded links to Game Maps don't work across both live and responsive sites.

When an embedded direct link to a Game Map is posted using the live site, the embed of the link is broken if viewed on responsive. Copy-pasting the link takes me to the map on live, which is what I suspect is breaking the embed. Not sure if it breaks if done the other way 'round, too, or if embedded links to other things are broken as well. I just happened to notice it with the Game Maps. Non-embedded links work just fine.
Raddek
 supporter, 17 posts
Fri 21 Feb 2020
at 15:28
Re: RPoL Design Update
Something odd that I've noticed recently is that I'm getting Not Secure notifications on the https:// sites both for responsive and live sites.  It is only here and there:  for example the main page and my game page does not show the advisory as soon as I go into one of the internal threads or the dice roller it does.  This may just be a Chrome thing, as I don't seem to have the same problem on Safari, though I haven't tried Edge or any other browser.
theseeker
 member, 24 posts
Mon 24 Feb 2020
at 05:23
Re: RPoL Design Update
Copy/paste the address on the displayed page when that happens.  Guessing that it will be http:// instead of https://.  Likely some links still hanging around that have not been converted to https.  Most links on the site will be relative (no http or https prefix), and will just use the same as the page the link is on.  But if some link is using the full url, including http, then that page, AND all pages that it links to using relative urls will then become insecure.  So need to find the *first* page the notification occurs on.  Jase might be able to locate it using a global search across the source for the whole site, looking for `http:`.  But it might be hiding in some generated code that gets included.

Can be fixed somewhat globally by setting the server to automatically and silently convert all incoming http requests to https.
Raddek
 supporter, 19 posts
Sat 7 Mar 2020
at 03:23
Re: RPoL Design Update
Sorry, been a little bit since I checked this thread.  I took a look at the https: switching randomly to http: and it seems like that isn't the problem.

As an example:  my character details page is showing not secure with a web address of: https://r.rpol.net/usermodules/profile.cgi?gi=58029 (obviously you won't be able to get there)

Likewise, some of my game threads are showing not secure like the one here: https://r.rpol.net/display.cgi?gi=58029&ti=49&date=1583550054

Oddly though, it makes a difference as to whether or not I am logged in.  If I copy paste the web address logged out, it shows secure, but logged in it shows not secure with both chrome and safari.
theseeker
 member, 27 posts
Sat 7 Mar 2020
at 05:25
Re: RPoL Design Update
That description probably means that the pages reporting not secure contain content that is using an http: link.  Likely culprit is an image.  Do you have an embedded profile image?  If the link to that is http: instead of https:, the whole containing page is marked as not secure.  Though some browsers, some versions, would show a slightly different message for that case, saying something about 'partially' not secure.

If you can not see the actual link, some browser / web developer tools will let you see every connection made while loading a page, and show whether the connection was secure or not.  It could also be a css or javascript file that is being loaded with the page.  I don't think a tutorial on web developer tools is appropriate here though.  I use Firefox tools mostly.  Chrome (at least) has similar.
Raddek
 supporter, 20 posts
Sat 7 Mar 2020
at 12:53
Re: RPoL Design Update
Yup, you nailed it.  Thanks for the help.
SunRuanEr
 subscriber, 237 posts
Sat 4 Apr 2020
at 00:58
Re: RPoL Design Update
Not sure if it's a Known Issue or not (I don't recall seeing it, but it's been a while), but Updating language groups on responsive doesn't seem to be sticking. Like, you check the box to add the language to the character, and then go hit 'Update', but the update doesn't take and the language group doesn't get added. (Tried this several times, so I know it wasn't a case of misclicking.)

Works fine on live.
muriwo
 member, 97 posts
Sun 5 Apr 2020
at 10:05
Feature Request: Responsive Site: Browser Notifications
[Could not find any way to search if this has already been requested - if it has, apologies].

Request: r.rpol.net can activate Browser Notifications for new Posts/PMs.   The user would activate this in his Preferences menu... then the site would ask the browser, which would ask the user for permission to enable such notifications.
At a basic level of implementation, there would either be notifications... or not.    At a more advanced level, the Preferences could be more fine-grained, for instance:
 - New Post in a Game I peruse
 - New Post in a Game I GM
 - New PM
 - New Rmail

Reason: RPOL has had the option to give email notifications, for many years.   I switched it off eons ago because I already get far too many emails from non-RPOL sources, and these notifications just add to the burden.    Whereas a browser notification lets me know something is happening if I am on my computer.   If I am not, it doesn't hassle me.

N.B. I don't know how difficult this is to implement from a scripting point of view.  Given that the new responsive site is a "ground-up rewrite", I just though that this feature might be easier to implement there.
Skald
 moderator, 892 posts
 Whatever it is,
 I'm against it
Sun 5 Apr 2020
at 10:34
Feature Request: Responsive Site: Browser Notifications
Just a thought ... is what you're asking for in anyway similar to RSS feeds ?  The old site has them, and it seems they're available on the new responsive site too (I don't use them, so can't attest to whether they're up and running on responsive yet, but I don't know there would have been much of a change in that functionality betwixt old and new).

Help file: RPoL faqs (rssfeeds)

And you can find the codes under Preferences | View your personal feeds
muriwo
 member, 98 posts
Sun 5 Apr 2020
at 11:54
Feature Request: Responsive Site: Browser Notifications
Thanks Skald, I believe that could work.

I have added a Feed Reader extension with Browser Notification to my browser, and then added the RPOL RSS feed URL to that.   Will see how it goes... looks like it will work.

I believe that for all users, a direct notification capacity might still be easier.   But certainly, not a high priority.
Zag24
 supporter, 607 posts
Tue 7 Apr 2020
at 14:34
Feature Request: Responsive Site: Browser Notifications
A really minor feature request:  After performing "Mark all as read" in a forum, do a window.history.popState() so that the back button does not just leave you in the forum, but instead returns to Home.
jase
 admin, 3744 posts
 Cogito, ergo procuro.
 Carpe stultus!
Wed 3 Jun 2020
at 12:21
Re: RPoL Design Update
After quite the delay I've copied in some updates.  What I can remember I've done is as follows;

  • Increased the "medium" wrap point to 960px (up from 800).  Small is up to 695px, medium up to 960 pixels.  In a nutshell this means that the side navigation menu will move out the way under 961 pixels wide and small (very narrow width) navigation options will kick in under 696 pixels.
  • Changed all of the logon and account registration pages (logon.cgi) to be responsive.
  • Changed the Wanted - Players search box to be responsive.
  • Changed a few lines in index.php using tables to div/responsive.
  • Changed even more in gameinfo.php.
  • Fixed layout when there was no side menu (namely the registration screens).
  • Changed some of the CSS "id" selectors to "class" to allow for better inheritance.
  • Changed profile (profile.cgi) screens to div/responsive.
  • Redid the portrait searching screen as a result/by-product of this.  The page unfortunately ends up being longer but hopefully much less cluttered and confusing… and though it's great when it happens I don’t think "I've managed to cram it all on one page" should be a design goal.  (c;
  • Added Vampire: The Masquerade 5th Edition to the dice roller.
  • Fixed updating of private groups.
  • Fixed updating of lurkers.
  • Fixed edit/delete links for private threads.
  • Edit:  Added Mayfair Exponential Game System to the dice roller.

If you're using a custom theme please update it.

Remember that the new roller options are only for those using the responsive site.

This message was last edited by the user at 10:27, Fri 05 June 2020.

Jhaelan
 member, 240 posts
 Prefers roles to rolls
 Based in UTC+1
Wed 3 Jun 2020
at 12:27
Re: RPoL Design Update
Great work, @jase! Thanks
SunRuanEr
 subscriber, 264 posts
Wed 3 Jun 2020
at 13:36
Re: RPoL Design Update
Awesome work, Jase! Thanks!

One question, though:
quote:
[*] Fixed edit/delete links for private threads.


What is this? I had thought upon first reading it that it was related to the issue I had mentioned a month or so back over in Technical Discussions about being unable to delete some PMs, but that issue is still happening.
jase
 admin, 3748 posts
 Cogito, ergo procuro.
 Carpe stultus!
Wed 3 Jun 2020
at 14:54
Re: RPoL Design Update
Edit issue was this one -- https://r.rpol.net/display.cgi?gi=36224&ti=909&date=1587831907

Also fixed the "This thread Thread closed" issue for closed threads.
Zag24
 supporter, 632 posts
Wed 3 Jun 2020
at 15:31
Re: RPoL Design Update
jase:
[*] Fixed updating of private groups.
[*] Fixed edit/delete links for private threads.[/list]

Confirm fixed!

Thanks, jase!  You're awesome, as always, and we deeply appreciate it.
nauthiz
 subscriber, 651 posts
Sat 6 Jun 2020
at 02:24
Re: RPoL Design Update
So the "Subscribe to support RPoL and receive added perks!" link on the responsive site doesn't seem to work.

Not sure if that's inhibited anyone from actually subscribing as it were, but it certainly adds a hurdle.
jase
 admin, 3752 posts
 Cogito, ergo procuro.
 Carpe stultus!
Sat 6 Jun 2020
at 03:17
Re: RPoL Design Update
Wow, thanks.  Been that way for about 11 months I figure.  Guess it's not being heavily utilised!  (c;
locojedi
 member, 186 posts
Mon 8 Jun 2020
at 19:20
Re: RPoL Design Update
Yeah, I'd tried the link a while ago and just figured you didn't have it working on purpose... shoulda said something I guess.
nauthiz
 subscriber, 654 posts
Fri 12 Jun 2020
at 03:57
Re: RPoL Design Update
I'm not sure how much work has been done on the "Browse/Search Games" section yet.

However it's currently a trap.  Once you actually go to the search page, the left/top navigation links stay the same as when you're on the main page (Wiki News Jump Chat rMail rPoll FAQs Help) instead of changing to the in game/forum set (Home Jump Chat rMail rPoll FAQs Help).

So you end up with the only obvious way to navigate back to the main page being using the back button on the browser.
Skald
 moderator, 903 posts
 Whatever it is,
 I'm against it
Fri 12 Jun 2020
at 13:16
Re: RPoL Design Update
Clicking on the impossible cube logo top right of the page will always take you back to the main menu - I agree that's not obvious, though.  :>
jase
 admin, 3758 posts
 Cogito, ergo procuro.
 Carpe stultus!
Sat 13 Jun 2020
at 13:35
Re: RPoL Design Update
Cube would be the way to go, but have added a close search link.